[Nottingham] Redhat Init

Robert Davies nottingham at mailman.lug.org.uk
Wed Jul 9 18:19:01 2003

On Wednesday 09 Jul 2003 16:36, Alex Tibbles wrote:

> Thanks for that (chkconfig, yes?). I'll look into that
> later when the program will be (probably) a
> start|stop|restart'able daemon.

Yes, it's ages since I used a distro where chkconfig was the right way to 
manage the rc?.d links, realised after I sent that a s/heck/hk/ was needed.

> S99local->../rc.local). Can you think of anything that
> would stop this working? My test was running exactly
> the same command as was in the rc.local from a root
> terminal (which worked). Do you know where I can find
> information about what went wrong? (Where is syslog on
> RH8 - it's not /var/log/syslog?!).

Rather than go and do mucho work, check out the obvious.  See the initial 
startup under root is *NOT* your normal environment, so plenty can go wrong.

I suggest that you wrap your invocation, with a script that redirect stdout 
and stderr to a log file, and stick in an 'env' command to check whether 
things like PATH, JAVAHOME, LD_LIBRARY_PATH and so on are as you need.

I'm still not sure if your process is a long running one, that hangs about 
waiting for 'action', or whether it's just something you want run on boot up, 
before logins occur.

One trick I've used for getting Oracle going is 'su - oracle -c orastart' or 
some such, which had the program started by correct login (not root) and also 
used the Oracle boys environment definitions, without having to copy them.