[Nottingham] Errr help...normal service please :-)

Robert Ross rross at dmu.ac.uk
Thu Nov 3 12:29:22 GMT 2005

Hi everyone,

I am trying to backup some websites and attendant mysql databases from one
server (SLES9) to another (Yellowdog 4) as well as some XP-based PCs. 
Began trying NFS but cannot get the XP clients to use it. 
Then tried Samba, but as the second server is on a different sub-net and the
routers are (apparently) blocking intra-subnet broadcasting (is that a
proper term?) the XP clients are still having difficulty access the server.

Then thought, sod the XP clients for the moment, just get the
server/databases sorted, so went to rdiff-backup for a neat way of doing
incremental backups and rotation.  Sorted out the passwordless access using
SSH2.  Had a few problems getting SLES to install rdiff-backup, but
eventually managed to get python sorted and from there rdiff-backup seems to

Next, looked at the Yellowdog server which is to hold the backups.  Used yum
to update everything (which was really good), but began to meet problems
with dependencies when installing rdiff-backup (no surprise there).
Eventually got it sorted (although I couldn't find a ppc-based rpm).  

Oh yeah, I'm using webmin as well as I'm crap at this sort of thing.

When it came to the python stage I again had to find various dependencies
(libpython2.4.so.1.0 - still no ppc rpm), but sorted it out.  After install
(and no errors given) I try to run python and get the following message 
python: relocation error: /usr/lib/libpython2.4.so.1.0: symbol
__vsnprintf_chk, version GLIBC_2.3.4 not defined in file libc.so.6 with link
time reference
I have the most up to date version of GLIBC (or at least I am told that by
yum) and I know there are meant to be shared libraries with python, which I
hope had been sorted at the install stage, so I am a bit flummoxed as to
what the above error is saying.  Has libpython been put in the wrong place?
Do I need to alter libc.so.6 (and what is a link time reference) or do I
need to do something with GLIBC. 
I am no hacker which is why I rely upon installation programmes like yum and
webmin.  I've Googled to no effect, so hopefully someone on the list may be
able to help.

In anticipation,


More information about the Nottingham mailing list