[Nottingham] Broken Kubuntu during feisty to gutsy upgrade

Dave daveluff at ntlworld.com
Mon Dec 10 22:36:03 GMT 2007

daveluff wrote:
> Martin wrote:
> I don't think it's an X problem - I get no keyboard even in single 
> user mode.  I think it's something pretty early in the startup 
> sequence, before X is started.
> [---]
>> Have you initialised for the wrong type of keyboard?
> Well, it was working before.  It's a fairly standard keyboard - an MS 
> natural PS2 one, but before all the multimedia cr%p got added, so 
> effectively it's a bog standard PS2 keyboard.
> The only possible clue I have, is that previously I'd get the same 
> symptoms in Feisty if I tried booting without the router and modem 
> switched on.  I wish I'd investigated further then now!
> I'll have a google...

Well, I've fixed it now.  Just in case anyone is interested or afflicted 
by the same problem...

It was definitely a Kubuntu problem on my hardware, not an installation 
issue, since the live CD had the same problem.

It turns out that lots of people with a PS2 keyboard and a USB mouse 
have been losing the keyboard after upgrading to either feisty or gutsy 
- that's the same combination of hardware that I'm using.

Taking the network card out would allow the keyboard to work, but 
obviously I need the network card!  It seems from the logs that both the 
PS2 system and then the ACPI PCI link were using IRQ12 - not sure if 
that's relevant or not.

Going into the BIOS and enabling USB legacy support fixed it, as noted 
on a Ubuntu forum by several posters.

Anyway, working now :-)

Cheers - Dave

More information about the Nottingham mailing list