[Nottingham] Slow mouse with high CPU

Jason Irwin jasonirwin73 at gmail.com
Thu May 17 08:50:59 UTC 2018

On 17/05/18 09:22, Daryl via Nottingham wrote:
> It's a Logitech Anywhere MX wireless mouse, the one with the dongle and not bluetooth. It's a new machine and 
> I didn't experience this when I ran Windows. I suspect that the USB ports are not being polled or responding 
> to interrupts or events.
I have only had similar issues with my MX 620 (unifying receiver) when Firefox or Thunderbird decide to peg the CPU (usually with swap going mental too). I simply considered it to be the system struggling as I would also be unable to close windows etc.

Under pure CPU loads...can't say I've noticed it, even when twitch-gaming (FPSs etc).

I can recall on some set-ups having to monkey around with power saving to stop the USB dongle getting shut off, but I can't think that's an issue here.

I'm on KDE (Kubuntu 16.04) and I am pretty sure I used to use "Solaar", but it doesn't look like I have anything Logitech-specific installed any more, and yet all the fancy buttons work. OK, I don't get battery stats but that's what the flashy LED on the mouse itself is for.

Oh now, there's a point. I *have* had issues where the battery is getting low but not enough to trigger the LED. Have you tried fresh batteries?

Interestingly I can see lots of complaints about this in Windows and Mac too; with many model of Logitech. No solutions though, sorry.

I could loan you my spare wireless mouse (Teknet) and you can see if that exhibits the same issue or not.
Let me know, I can bring it tonight.

║ Jason Irwin ║ OpenPGP (GPG/PGP) Public Key: 0xD0C592B1    ║
║             ║ Import from hkp://pgp.mit.edu               ║
║             ║ Follow me https://social.irrwitz.com/@jason ║

More information about the Nottingham mailing list