[sclug] veeeerrrrryyyy looooong delay booting (initrd)

John Stumbles john at stumbles.org.uk
Sat Aug 12 09:35:22 UTC 2006

Will Dickson wrote:
> Ed Davies wrote:
>> I think it's because I have my disks on a UDMA card - not
>> on either of the IDE buses on the motherboard.  /dev/hda &
>> b don't exist.  The CD drives are /dev/hdc & d and the hard
>> disks are /dev/hde & f.  My suspicion is that the system is
>> taking a lot of time to give up probing the motherboard
>> IDEs.

<groan> I had something like that with a previous PC that had a separate 
hdd card. It would try hda .... nope nothing there, try hdb ... nope not 
there either, chunter chunter ... then go through trying hda and b 
*again* ffs! (I think that was with SuSE, maybe Hoary.)

 >> This is only a guess, though.

In my machine's case you could see it in the boot up messages on the 

> FWIW (probably not much :-) I don't have any IDE hard drives at all - 
> mine's SATA, which thinks it's SCSI. DVD/CD-RW combo drive on /dev/hdc, 
> Zip drive on /dev/hdd.

SATA == Serial ATA? So do you have a small cable with a few conductors 
connecting them instead of a 40 (or 80) way ribbon?

(Shows the age of my PC hardware I've never come across such a thing :-))

> Have you tried disabling the unused IDE channel in the CMOS?

I haven't tried anything: apart from having 10^large_number+1 other 
things to do I think it's a worthwhile learning exercise for him to do 
it  :-)    (with a little encouragement and help as necessary when he 
gets out of his depth)

John Stumbles

More information about the Sclug mailing list